
Fokker organ emulator for Hauptwerk, version 0.4

by Ere Lievonen

The Fokker Emulator is a Custom Organ Definition file for Hauptwerk that enables the Hauptwerk Virtual Organ 
software to emulate the microtonal (31 tones / octave) Fokker organ, situated in the Muziekgebouw aan 't IJ in 
Amsterdam. The Fokker Emulator does not contain samples of the Fokker organ itself, but instead uses selected 
samples (slightly modified) of similar registers from the St. Anne's, Moseley organ sample set that comes 
standard with the Hauptwerk software. The sounds of these samples are of course not entirely identical to the 
Fokker organ, but they are similar enough to give a good idea of the Fokker organ's sound.

Instructions for installation:

Step 1:
– Download and install the Hauptwerk software from http://www.hauptwerk.com/
This software is available for both Mac and Windows. For exact system requirements, please refer to the 
Hauptwerk website.

Note:
The Fokker organ emulator will work also on the Free Edition of Hauptwerk. The free edition has some limitations, though – 
most notably the maximum of 256 simultaneously sounding pipes (including their reverb/decays). This may not be enough for 
very dense textures or large clusters. Also the wind pressure modelling is not included in the Free Edition. If you'll be using 
Hauptwerk on a regular basis, please do support the development of this fabulous software by buying a license for the Basic 
or Advanced Edition – it is well worth the money for the best virtual organ software available.

Step 2:
– Download FokkerEmulator-v0.4.zip and open/unpack it.
– Move the file FokkerEmulator-v0.4.CustomOrgan_Hauptwerk_xml to the folder named 
Hauptwerk/HauptwerkUserData/CustomOrganDefinitions on your computer.
– Move the file 31ToneEqual.Temperament_Hauptwerk_xml to the folder named 
Hauptwerk/HauptwerkSampleSetsAndComponents/Temperaments on your computer.

Step 3:
– Start Hauptwerk, and go through the General Configuration Wizard. Here you will select which MIDI port you'll 
use to send MIDI to Hauptwerk, and which audio output you'll use.

Note:
On a Mac, you probably will use an IAC bus for sending MIDI to Hauptwerk. If the IAC driver isn't activated on your Mac yet: 
go to Applications, find and open Audio and MIDI Settings, select Window > Show MIDI window, double-click on IAC Driver, 
make sure that at least one bus/port exists (two buses is recommended), and put a checkmark at Device is online. (Then go 
back to step 3.)

Step 4:
– In Hauptwerk, select Design tools > Load custom organ > FokkerEmulator-v0.4.
– You don't need to change anything in the options windows that follow; just click OK.

Step 5:
The Fokker Emulator will now be loaded and started. When this is done, there will be four floating control panels 
on top of the main window. 
– Find the Pitch panel, and click the Temperament: Load... button. Select 31ToneEqual.
– Set Base pitch Hz: A= to 443.0, using the arrow buttons. This is the pitch that the real Fokker organ is tuned at.
(You can now see at the top right of the main window that the temperament is set to 31-TET, and on the status 
bar at the bottom of the window that the Pitch is set to 443.0.)
– You may now close all four of the floating control panels (click the X at the top left corner of the panels).

Step 6:
This step is optional, but will tell you which "mini control panels" I've found most useful to have on screen at all 
times when using the Fokker Emulator. 
– By default, Hauptwerk places two such control panels at the top of the window, and one row of buttons at the 
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bottom. Close all three of these (right-click on each and choose Close this control panel/toolbar).
– Select View > Mini control panels > Engine status and reset. If you happen to get hanging notes, you can 
press the Keys button to send an "All Notes Off" command. (The All button turns off all the registers as well.)
– Select View > Mini control panels > Audio output level. With this you can easily adjust the output volume. You 
may need to raise the level (Trim dB) to about +15 dB to start with. 
– Now grab the left edge of the Audio control panel and move it on top of the Engine panel, so that they will 
condense and fit on one row.
– The display may look better when the option View > Zoom virtual console to fit is on or off, depending on your 
screen resolution and window size. Try it both ways.
– If you wish Fokker Emulator to be automatically loaded the next time Hauptwerk starts, go to General 
settings > General preferences, and set Load organ when Hauptwerk starts? to Load last-used organ.

Tip:
A few useful indicators are located at the bottom right corner of the main window, namely: Audio level, Polyphony (this 
shows whether you're approaching the maximum of possible simultaneously sounding pipes), CPU usage (there will be audio 
hiccups if your CPU becomes overloaded), and RAM usage (this can be a problem on smaller laptop computers). These 
indicators are also available as "mini control panels", should you like them to be better visible.

Step 7:
– Quit Hauptwerk.
– Find folder Hauptwerk/HauptwerkUserData/Config0-OrganSettings on your computer, and open file 
OrganID803104Config.OrganConfig_Hauptwerk_xml in a text editor (such as Notepad).
– Find the line that reads

<ObjectList ObjectType="KeyboardInputOutput">

– Replace the nine lines that follow with these:

<o><a>1</a><c>1</c><e>4</e><f>37</f><g>54</g><h>37</h><i>1e+2</i><j>5e+1</j></o>
<o><a>8</a><c>1</c><e>5</e><f>37</f><g>53</g><h>37</h><i>1e+2</i><j>5e+1</j></o>
<o><a>9</a><c>1</c><e>6</e><f>37</f><g>53</g><h>37</h><i>1e+2</i><j>5e+1</j></o>
<o><a>2</a><c>1</c><e>1</e><f>37</f><g>92</g><h>37</h><i>1e+2</i><j>5e+1</j></o>
<o><a>3</a><c>1</c><e>2</e><f>37</f><g>91</g><h>37</h><i>1e+2</i><j>5e+1</j></o>
<o><a>4</a><c>1</c><e>3</e><f>37</f><g>91</g><h>37</h><i>1e+2</i><j>5e+1</j></o>
<o><a>5</a><c>1</c><e>7</e><f>37</f><g>92</g><h>37</h><i>1e+2</i><j>5e+1</j></o>
<o><a>6</a><c>1</c><e>8</e><f>37</f><g>91</g><h>37</h><i>1e+2</i><j>5e+1</j></o>
<o><a>7</a><c>1</c><e>9</e><f>37</f><g>91</g><h>37</h><i>1e+2</i><j>5e+1</j></o>

– Find the line that reads 

<ObjectList ObjectType="SwitchInputOutput">

– Scroll down to the end of this particular ObjectList section, and replace the last 19 lines (starting from the line 
<o><a>2001</a></o>) with these:

<o><a>2001</a><c>2</c><h>1</h><k>1</k><l>2</l></o>
<o><a>2002</a><c>2</c><h>1</h><k>3</k><l>4</l></o>
<o><a>2205</a><c>2</c><h>1</h><k>9</k><l>10</l></o>
<o><a>2206</a><c>2</c><h>1</h><k>11</k><l>12</l></o>
<o><a>2408</a><c>2</c><h>1</h><k>15</k><l>16</l></o>
<o><a>2409</a><c>2</c><h>1</h><k>17</k><l>18</l></o>
<o><a>2631</a><c>2</c><h>1</h><k>19</k><l>20</l></o>
<o><a>2632</a><c>2</c><h>1</h><k>21</k><l>22</l></o>
<o><a>2633</a><c>2</c><h>1</h><k>23</k><l>24</l></o>
<o><a>2634</a><c>2</c><h>1</h><k>25</k><l>26</l></o>
<o><a>2635</a><c>2</c><h>1</h><k>27</k><l>28</l></o>
<o><a>2636</a><c>2</c><h>1</h><k>29</k><l>30</l></o>
<o><a>2637</a><c>2</c><h>1</h><k>31</k><l>32</l></o>
<o><a>2638</a><c>2</c><h>1</h><k>33</k><l>34</l></o>
<o><a>2639</a><c>2</c><h>1</h><k>35</k><l>36</l></o>
<o><a>2640</a><c>2</c><h>1</h><k>37</k><l>38</l></o>
<o><a>1006</a><c>2</c><h>1</h><k>5</k><l>6</l></o>
<o><a>1021</a><c>2</c><h>1</h><k>7</k><l>8</l></o>
<o><a>1226</a><c>2</c><h>1</h><k>13</k><l>14</l></o>

– Save the file and quit the text editor. 



The above will configure your Hauptwerk setup to understand the MIDI messages that the real Fokker organ 
uses (Method 3). (Doing these settings manually in Hauptwerk would also be possible, only much slower.)

Step 8:
The installation is now complete. 
– To use the Fokker Emulator, start Hauptwerk again, then (if you didn't set Hauptwerk to load Fokker Emulator 
automatically) select Organ > Load organ > FokkerEmulator-v0.4.
– You can now send MIDI messages to the Fokker Emulator just like you would to the real Fokker organ (using 
Method 3). For a list of the MIDI messages that the Fokker organ uses, see the Appendix below. 
– You can also control the Fokker Emulator by clicking on the on-screen items.

Tip:
You can play 31-tone music on the Fokker Emulator by using several 12-tone MIDI keyboards. For example, to emulate a 
complete 31-tone Manual I, you need three regular MIDI keyboards that transmit on channels 1, 2 and 3. (If you only want to 
use the Fokker Emulator in this way, you could also go to Organ settings > Keyboards, and adjust the input settings to 
conform to your keyboard set-up.)

Note:
If your computer's memory resources are not sufficient to run the Fokker Emulator smoothly using the default settings, the 
easiest solution is to switch to using mono samples instead of stereo samples. Go to Organ > Load organ, adjusting rank 
audio/memory options/routing > FokkerEmulator-v0.4. Select all 15 items from the list on the left; then on the right, change 
Memory channel format to Mono, and click OK. 
Notice that after reloading the organ you may have to set the pitch again to 443 Hz (go to Pitch > Organ base pitch)!

Important remarks for composers creating MIDI files:
– On the real Fokker organ, notes shorter than about 20 milliseconds will not sound at all, as the pipes won't have enough 
time to speak. (Moreover, low pipes speak more slowly than higher pipes.) On the Fokker Emulator, however, even the 
shortest staccato notes do sound, because Hauptwerk appears to have a set minimum length for notes played.
– On the real Fokker organ, a sounding pipe needs some time to stop speaking before the same pipe can produce a new 
attack; thus a note repeated immediately again (with not enough silence inbetween) will sound like a tied note. On the Fokker 
Emulator, however, repeated notes always get a new attack.
– Even though the Fokker Emulator can play 12 notes in an octave also on channels 3, 6 and 9, the real Fokker organ only 
responds to the notes given in the MIDI messages table below (i.e. there are only 7 notes per octave on channels 3, 6 and 
9).

Known issues:
– MIDI files made to be played on the Fokker organ are not compatible with Hauptwerk's built-in MIDI player. Instead, use an 
external MIDI player application to send MIDI data to the Fokker Emulator.
– MIDI performances recorded on the real Fokker organ (or other MIDI files intended for the Fokker organ) may contain 
unintentional, extremely short "notes" that remain inaudible on the real organ – for example in connection with a nearly 
simultaneous register change – but that become audible on the Fokker Emulator. This is because Hauptwerk appears to 
have a set minimum length for notes played.
– The ten small buttons on the left currently do not send any messages (this is the case also on the real Fokker organ). They 
can be switched on and off, though, so they may be used as indicator lights.
– The Fokker Emulator does not (yet) emulate any stop and key action noises.

Ere Lievonen
Version 29.12.2012



Appendix

MIDI messages for the Fokker organ (Method 3)

Manual I

Pitch Channel Note # Pitch Channel Note # Pitch Channel Note #

C 1 36 C+ 2 36
C# 1 37 Db 2 37 D- 3 37
D 1 38 D+ 2 38 D# 3 38
Eb 1 39 E- 2 39
E 1 40 E+ / Fb 2 40 E# / F- 3 40
F 1 41 F+ 2 41
F# 1 42 Gb 2 42 G- 3 42
G 1 43 G+ 2 43
G# 1 44 Ab 2 44 A- 3 44
A 1 45 A+ 2 45 A# 3 45
Bb 1 46 B- 2 46
B 1 47 B+ / cb 2 47 B# / c- 3 47

c 1 48 c+ 2 48
c# 1 49 db 2 49 d- 3 49
d 1 50 d+ 2 50 d# 3 50
eb 1 51 e- 2 51
e 1 52 e+ / fb 2 52 e# / f- 3 52
f 1 53 f+ 2 53
f# 1 54 gb 2 54 g- 3 54
g 1 55 g+ 2 55
g# 1 56 ab 2 56 a- 3 56
a 1 57 a+ 2 57 a# 3 57
bb 1 58 b- 2 58
b 1 59 b+ / cb1 2 59 b# / c-1 3 59

c1 1 60 c+1 2 60
c#1 1 61 db1 2 61 d-1 3 61
d1 1 62 d+1 2 62 d#1 3 62
eb1 1 63 e-1 2 63
e1 1 64 e+1 / fb1 2 64 e#1 / f-1 3 64
f1 1 65 f+1 2 65
f#1 1 66 gb1 2 66 g-1 3 66
g1 1 67 g+1 2 67
g#1 1 68 ab1 2 68 a-1 3 68
a1 1 69 a+1 2 69 a#1 3 69
bb1 1 70 b-1 2 70
b1 1 71 b+1 / cb2 2 71 b#1 / c-2 3 71

c2 1 72 c+2 2 72
c#2 1 73 db2 2 73 d-2 3 73
d2 1 74 d+2 2 74 d#2 3 74
eb2 1 75 e-2 2 75
e2 1 76 e+2 / fb2 2 76 e#2 / f-2 3 76
f2 1 77 f+2 2 77
f#2 1 78 gb2 2 78 g-2 3 78
g2 1 79 g+2 2 79
g#2 1 80 ab2 2 80 a-2 3 80
a2 1 81 a+2 2 81 a#2 3 81
bb2 1 82 b-2 2 82
b2 1 83 b+2 / cb3 2 83 b#2 / c-3 3 83

c3 1 84 c+3 2 84
c#3 1 85 db3 2 85 d-3 3 85
d3 1 86 d+3 2 86 d#3 3 86
eb3 1 87 e-3 2 87
e3 1 88 e+3 / fb3 2 88 e#3 / f-3 3 88
f3 1 89 f+3 2 89
f#3 1 90 gb3 2 90 g-3 3 90
g3 1 91



Manual II

Pitch Channel Note # Pitch Channel Note # Pitch Channel Note #

C 7 36 C+ 8 36
C# 7 37 Db 8 37 D- 9 37
D 7 38 D+ 8 38 D# 9 38
Eb 7 39 E- 8 39
E 7 40 E+ / Fb 8 40 E# / F- 9 40
F 7 41 F+ 8 41
F# 7 42 Gb 8 42 G- 9 42
G 7 43 G+ 8 43
G# 7 44 Ab 8 44 A- 9 44
A 7 45 A+ 8 45 A# 9 45
Bb 7 46 B- 8 46
B 7 47 B+ / cb 8 47 B# / c- 9 47

c 7 48 c+ 8 48
c# 7 49 db 8 49 d- 9 49
d 7 50 d+ 8 50 d# 9 50
eb 7 51 e- 8 51
e 7 52 e+ / fb 8 52 e# / f- 9 52
f 7 53 f+ 8 53
f# 7 54 gb 8 54 g- 9 54
g 7 55 g+ 8 55
g# 7 56 ab 8 56 a- 9 56
a 7 57 a+ 8 57 a# 9 57
bb 7 58 b- 8 58
b 7 59 b+ / cb1 8 59 b# / c-1 9 59

c1 7 60 c+1 8 60
c#1 7 61 db1 8 61 d-1 9 61
d1 7 62 d+1 8 62 d#1 9 62
eb1 7 63 e-1 8 63
e1 7 64 e+1 / fb1 8 64 e#1 / f-1 9 64
f1 7 65 f+1 8 65
f#1 7 66 gb1 8 66 g-1 9 66
g1 7 67 g+1 8 67
g#1 7 68 ab1 8 68 a-1 9 68
a1 7 69 a+1 8 69 a#1 9 69
bb1 7 70 b-1 8 70
b1 7 71 b+1 / cb2 8 71 b#1 / c-2 9 71

c2 7 72 c+2 8 72
c#2 7 73 db2 8 73 d-2 9 73
d2 7 74 d+2 8 74 d#2 9 74
eb2 7 75 e-2 8 75
e2 7 76 e+2 / fb2 8 76 e#2 / f-2 9 76
f2 7 77 f+2 8 77
f#2 7 78 gb2 8 78 g-2 9 78
g2 7 79 g+2 8 79
g#2 7 80 ab2 8 80 a-2 9 80
a2 7 81 a+2 8 81 a#2 9 81
bb2 7 82 b-2 8 82
b2 7 83 b+2 / cb3 8 83 b#2 / c-3 9 83

c3 7 84 c+3 8 84
c#3 7 85 db3 8 85 d-3 9 85
d3 7 86 d+3 8 86 d#3 9 86
eb3 7 87 e-3 8 87
e3 7 88 e+3 / fb3 8 88 e#3 / f-3 9 88
f3 7 89 f+3 8 89
f#3 7 90 gb3 8 90 g-3 9 90
g3 7 91



Pedal

Pitch Channel Note # Pitch Channel Note # Pitch Channel Note #

C 4 36 C+ 5 36
C# 4 37 Db 5 37 D- 6 37
D 4 38 D+ 5 38 D# 6 38
Eb 4 39 E- 5 39
E 4 40 E+ / Fb 5 40 E# / F- 6 40
F 4 41 F+ 5 41
F# 4 42 Gb 5 42 G- 6 42
G 4 43 G+ 5 43
G# 4 44 Ab 5 44 A- 6 44
A 4 45 A+ 5 45 A# 6 45
Bb 4 46 B- 5 46
B 4 47 B+ / cb 5 47 B# / c- 6 47

c 4 48 c+ 5 48
c# 4 49 db 5 49 d- 6 49
d 4 50 d+ 5 50 d# 6 50
eb 4 51 e- 5 51
e 4 52 e+ / fb 5 52 e# / f- 6 52
f 4 53

Registers

MIDI program change messages on Channel 1:

Stop on off

1   Subbas 16’ 0 1
2   Gedekt 8’ 2 3
3   P + I 4 5
4   P + II 6 7
5   Quintadena 8’ 8 9
6   Prestant 4’ 10 11
7   I + II 12 13
8   Salicionaal 8’ 14 15
9   Roerfluit 4’ 16 17

Buttons (currently non-functional)

MIDI program change messages on Channel 1:

Button on off

1 18 19
2 20 21
3 22 23
4 24 25
5 26 27
6 28 29
7 30 31
8 32 33
9 34 35
10 36 37


